Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Reverted from v. 27
German

Die Menüleiste am oberen Bildschirmrand zeigt einige der Menüpunkte an. Sie besteht aus den Menüpunkten “Datei”, “Bearbeiten”, “XML”, “Werkzeuge”, “Fenster”, und “Hilfe”.

Unter dem Menüpunkt “Datei” können Sie folgende Aktionen durchführen:

  • Aggregationen verwalten

  • Projekte, Objekte und lokale Dateien erstellen, öffnen, speichern und schließen

  • Revisionen verwalten

  • Veröffentlichen 

  • ein Objekt über seinen URI öffnen oder den URI kopieren

  • Metadaten verwalten

  • Importieren Image Removed und Exportieren Image Removed

  • Netzwerk-Warnungen ausblenden

  • das TextGridLab erneut starten Image Removed oder beenden Image Removed

Wenn der XML-Editor oXygen installiert ist, kann ein URL für eine FTP- oder SFTP-Verbindung mit dem oXygen WebDAV-Support geöffnet werden.

Der Menüpunkt “Bearbeiten” bietet Funktionen für den XML-Editor und den Text-Bild-Link-Editor wie "Rückgängig", "Ausschneiden" und "Einfügen" oder "Suchen und Ersetzen".

Unter dem Menüpunkt “XML” finden Sie Funktionen für die Bearbeitung von XML-Quelltext im XML-Editor. Der Punkt "XML" wird ausführlich im Abschnitt zur Menüleiste im Kapitel XML Editor beschrieben.

Der Menüpunkt “Werkzeuge” erlaubt Ihnen jederzeit, die meisten wichtigen Werkzeuge zu öffnen. Unter dem Unterpunkt “Sicht anzeigen” können Sie die TextGrid-Sichten öffnen, d.h. den Navigator, die Wörterbuchsuchergebnisse-Sicht, den Metadata Editor und die Unicode-Zeichen-Tabelle (zuzüglich weiterer Sichten, die größtenteils in den Eclipse-Dokumentation beschrieben sind: http://www.eclipse.org/documentation/).

Der Menüpunkt “Fenster” erlaubt Ihnen, mit dem Unterpunkt „Neuer Editor“ Image Removed eine neue Editor-Sicht zu öffnen, wenn bereits ein Editor geöffnet ist. Darüber hinaus bietet der Menüpunkt Optionen, die das Navigieren im Laboratory unterstütze. So können Sie

  • das Erscheinungsbild von "Schnellsichten" festlegen, wenn Sie den Unterpunkt "Navigation Image Removed> Schnellzugriff" auswählen

  • Editoren öffnen und zwischen ihnen wechseln

  • geöffnete Editoren minimieren und maximieren

  • die vorherige Perspektive oder Sicht auswählen

Unter “Fenster” können Sie außerdem die Benutzervorgaben (Image Removed) ändern. Die meisten Optionen sind in der Eclipse Dokumentation (http://www.eclipse.org/documentation/) beschrieben, aber manche Benutzervorgaben betreffen nur das TextGridLab selbst:

  • Die “Zuordnung von TextGrid-Inhaltstypen und Dateiendungen” konfiguriert die Zuordnung zwischen TextGrid-Inhaltstypen (als regulärer Ausdruck, der zum Inhaltstyp-Metadatenfeld von Objekten passt) und den internen Dateiendungen.

  • In den “TextGridLab-Dialogeinstellungen” können Sie wählen, ob CRUD-Warnungen angezeigt werden sollen, um auf Datenbankprobleme hinzuweisen.

  • In “TextGridLab-Server und -Proxy,” können der Proxy-Server und der (un)komprimierte Datenverkehr konfiguriert werden.

Es gibt außerdem ein paar Möglichkeiten, die Benutzervorgaben verschiedener Module zu ändern, die installiert sind.

Unter “Hilfe” können Sie in der Menüleiste

  • den Startbildschirm öffnen

  • Ihre Authentifizierungsdaten einsehen und ändern

  • Hilfe-Funktion verwenden

  • eine Fehlermeldung abschicken und die Log-Datei speichern

  • Tastaturkürzel unter dem Menüpunkt “Hilfe für Tastenbelegung...” einsehen

  • auf Updates prüfen und neue Software installieren

  • weitere Werkzeuge und Dienst über den "Eclipse Marketplace" installieren

  • Informationen über die aktuelle TextGrid-Version erhalten

Manche Module wie der XML-Editor oXygen bieten außerdem einige Besonderheiten im "Hilfe"-Menü an, wenn sie installiert sind.

...

The menu bar at the top of the screen displays some of the menu items. It consists of the following items: “File”, “Edit”, “XML”, “Tools”, “Window”, and “Help”.

Under the item labelled “File” you can manage:

  • manage Aggregations
  • create, open, save, and close Projects, Objects, and local files
  • manage Revisions
  • Publish 
  • open an Object via its URI or copy the URI
  • manage  Metadata 
  •  ImportImage Modified and Export Image Modified
  •  hide network warnings
  •  restart Image Modified or exit Image Modified the TextGridLab

If the oXygen XML editor is installed, a URL for a FTP or SFTP connection can be opened with the oXygen WebDAV support.

The item labelled “Edit” offers operations for the XML Editor and the Text Image Link Editor, such as "Undo", "Cut" and "Paste" or "Find and Replace".

Under the item labelled “XML” you can find functions for working with XML code in the XML Editor. Therefore, "XML" will be discussed more fully in the menu bar chapter about the XML Editor.

The item labelled “Tools” allows you to open the most important tools at any time. Using the sub-item “Show View” you can open the TextGrid views, i.e. the Navigator, the Dictionary Results View, the Metadata Editor and the Unicode Character Table (in addition to others that are, for the most part, described in the Eclipse documentation: http://www.eclipse.org/documentation/).

The item labelled “Window” enables you to open a new editor view if an editor is already open, using this icon (Image Modified). Furthermore, it offers you options to aid in navigating the Laboratory, since you can

  • define the appearance of "fast views" when opened using the sub-item "Navigation Image Modified > Quick Access"
  • open and switch between editors
  • minimize and maximize open editors
  • choose the previous perspective, editor, or view

In “Window” you can also change the preferences (Image Modified). Most of the possibilities are described in the Eclipse documentation (http://www.eclipse.org/documentation/), but some preferences will affect the TextGridLab directly:

  • The “TextGrid Content Types and File Extension Mapping” configures the mapping between TextGrid Content Types (as regular expression matching the content type metadata field of objects) and the internal file extensions.
  • In the “TextGridLab Dialog Settings” the user can choose if CRUD warnings should be shown to indicate database problems.
  • In “TextGridLab Server and Proxy,” the proxy server and compressed data transfer can be configured.

There are also some possibilities to change the preferences of different modules that might have been installed.

Under “Help” in the menu bar, you can

  • open the Welcome Screen
  • view and change your authentication data
  • use the

...

  • Help function
  • report a bug and save the logfile
  • view keyboard shortcuts by clicking “Key Assist...”
  • handle software updates
  • receive additional tools and services via the "Eclipse Marketplace"
  • receive information about the current TextGrid version

Some modules like the oXygen XML editor also offer some features in the "Help" menu if installed.