Page tree
Skip to end of metadata
Go to start of metadata

Die Menüleiste am oberen Bildschirmrand zeigt einige der Menüpunkte an. Sie besteht aus den Menüpunkten “Datei”, “Bearbeiten”, “XML”, “Werkzeuge”, “Fenster”, und “Hilfe”.

Unter dem Menüpunkt “Datei” können Sie folgende Aktionen durchführen:

Wenn der XML-Editor oXygen installiert ist, kann ein URL für eine FTP- oder SFTP-Verbindung mit dem oXygen WebDAV-Support geöffnet werden.

Der Menüpunkt “Bearbeiten” bietet Funktionen für den XML-Editor und den Text-Bild-Link-Editor wie "Rückgängig", "Ausschneiden" und "Einfügen" oder "Suchen und Ersetzen".

Unter dem Menüpunkt “XML” finden Sie Funktionen für die Bearbeitung von XML-Quelltext im XML-Editor. Der Punkt "XML" wird ausführlich im Abschnitt zur Menüleiste im Kapitel XML Editor beschrieben.

Der Menüpunkt “Werkzeuge” erlaubt Ihnen jederzeit, die meisten wichtigen Werkzeuge zu öffnen. Unter dem Unterpunkt “Sicht anzeigen” können Sie die TextGrid-Sichten öffnen, d.h. den Navigator, die Wörterbuchsuchergebnisse-Sicht, den Metadata Editor und die Unicode-Zeichen-Tabelle (zuzüglich weiterer Sichten, die größtenteils in den Eclipse-Dokumentation beschrieben sind: http://www.eclipse.org/documentation/).

Der Menüpunkt “Fenster” erlaubt Ihnen, mit dem Unterpunkt „Neuer Editor“  eine neue Editor-Sicht zu öffnen, wenn bereits ein Editor geöffnet ist. Darüber hinaus bietet der Menüpunkt Optionen, die das Navigieren im Laboratory unterstütze. So können Sie

  • das Erscheinungsbild von "Schnellsichten" festlegen, wenn Sie den Unterpunkt "Navigation > Schnellzugriff" auswählen

  • Editoren öffnen und zwischen ihnen wechseln

  • geöffnete Editoren minimieren und maximieren

  • die vorherige Perspektive oder Sicht auswählen

Unter “Fenster” können Sie außerdem die Benutzervorgaben () ändern. Die meisten Optionen sind in der Eclipse Dokumentation (http://www.eclipse.org/documentation/) beschrieben, aber manche Benutzervorgaben betreffen nur das TextGridLab selbst:

  • Die “Zuordnung von TextGrid-Inhaltstypen und Dateiendungen” konfiguriert die Zuordnung zwischen TextGrid-Inhaltstypen (als regulärer Ausdruck, der zum Inhaltstyp-Metadatenfeld von Objekten passt) und den internen Dateiendungen.

  • In den “TextGridLab-Dialogeinstellungen” können Sie wählen, ob CRUD-Warnungen angezeigt werden sollen, um auf Datenbankprobleme hinzuweisen.

  • In “TextGridLab-Server und -Proxy,” können der Proxy-Server und der (un)komprimierte Datenverkehr konfiguriert werden.

Es gibt außerdem ein paar Möglichkeiten, die Benutzervorgaben verschiedener Module zu ändern, die installiert sind.

Unter “Hilfe” können Sie in der Menüleiste

  • den Startbildschirm öffnen

  • Ihre Authentifizierungsdaten einsehen und ändern

  • Hilfe-Funktion verwenden

  • eine Fehlermeldung abschicken und die Log-Datei speichern

  • Tastaturkürzel unter dem Menüpunkt “Hilfe für Tastenbelegung...” einsehen

  • auf Updates prüfen und neue Software installieren

  • weitere Werkzeuge und Dienst über den "Eclipse Marketplace" installieren

  • Informationen über die aktuelle TextGrid-Version erhalten

Manche Module wie der XML-Editor oXygen bieten außerdem einige Besonderheiten im "Hilfe"-Menü an, wenn sie installiert sind.

 

  • No labels