Installing software directly from update sites

To browse an update site and directly install software from it (that may not yet be part of the Marketplace), 

  1. Open the wizard at Help → Install New Software
  2. Select the update site you want to browse from the Work with drop down, or enter its URL (see the list above) into the drop down's input field and press your Enter key
  3. Check the tool(s) you wish to install in the tree below
  4. Work through the rest of the wizard using the Next and Finish buttons.

You will need to restart the TextGridLab after installing software.

You are not neccessarily limited to TextGridLab tools – you can theoretically install any Eclipse plug-in into the TextGridLab using this method. However, tools that are neither at our update site nor in our marketplace have not been tested to work with TextGridLab, and thus may not work.

Removing tools

You can remove tools you no longer need from your TextGridLab installation by way of the installation detail dialog:

  1. Open the About TextGridLab dialog from the Help menu (or the TextGridLab menu on Mac OS)
  2. Click the Installation Details button to open the corresponding dialog
  3. On the Installed Software page, select the tool(s) you wish to uninstall and click the Uninstall button.
  4. The uninstall wizard will list everything to be uninstalled. Click Finish.
  5. After uninstallation, you should restart the TextGridLab as recommended.

Note that you cannot remove tools that are TextGridLab base components or that other tools depend on.


Software direkt von Update-Websites installieren

Um eine Update-Website zu durchsuchen und Software, die eventuell noch nicht im Marketplace zur Verfügung steht, direkt von der Seite zu installieren, müssen Sie:

  1. den Assistenten über den Unterpunkt „Neue Software installieren…“ im Menü „Hilfe“ öffnen,

  2. die Update-Website, die Sie durchsuchen wollen, aus dem Aufklappmenü unter “Arbeiten mit:” auswählen, oder ihren URL (siehe obige Liste) in das Eingabefeld eingeben und die Eingabetaste drücken,

  3. in der Baumstruktur darunter das/die Werkzeug(e) auswählen, das/die Sie installieren wollen und

  4. die weiteren Schritte im Assistenten unter Verwendung der Schaltflächen „Weiter“ und „Fertigstellen“ durchführen.

Nach der Installation von Software werden Sie das TextGridLab neu starten müssen.

Sie sind dabei nicht auf Werkzeuge des TextGridLab beschränkt – theoretisch können Sie auf diese Weise jedes beliebige Eclipse-Plug-in in das TextGridLab installieren. Werkzeuge, die weder auf unseren Update-Websites noch in unserem Marketplace angeboten werden, wurden jedoch nicht auf ihre Funktionsfähigkeit im TextGridLab geprüft und funktionieren daher möglicherweise nicht.

Werkzeuge entfernen

Sie können Werkzeuge, die Sie nicht mehr benötigen, über den Assistenten „Installationsdetails“ aus Ihrer Installation des TextGridLab entfernen:

  1. Wählen Sie den Unterpunkt “Info über TextGridLab” im Menü „Hilfe“ (oder „TextGridLab“ unter Mac OS).

  2. Klicken Sie die Schaltfläche “Installationsdetails, um den entsprechenden Assistenten zu öffnen.

  3. Wählen Sie unter dem Reiter “Installierte Software” das oder die Werkzeug(e) aus, das Sie deinstallieren wollen, und klicken Sie „Deinstallieren“.

  4. Der Assistent “Deinstallieren” listet alle Elemente auf, die deinstalliert werden sollen. Klicken Sie „Fertigstellen“.

  5. Nach dem Deinstallieren sollten Sie das TextGridLab wie empfohlen neu starten.

Nehmen Sie zur Kenntnis, dass Sie keine Werkzeuge entfernen können, die zur den Kernkomponenten des TextGridLab zählen oder von anderen Werkzeugen benötigt werden.