The current version of the TextGridLab (TextGridLab Base) offers all of the basic components. The Lab is available as a free download from the TextGrid website for various operating systems:

http://www.textgridlab.org/download/2.0/

PlugIns and a variety of external tools adapted for usage within TextGridLab can be downloaded for free via the Marketplace from the Welcome Screen or at any point from the Lab.


System Requirements

  • Java

Since version 3.3, TextGridLab bundles Java and thus prevents problems that could occur with not suitably installed or missing Java packages. Versions 3.2 and earlier of the TextGridLab used to require a Java Runtime Environment (JRE), version 6 or higher. Download:

http://java.com/download

  • Linux

On Linux, you will also need version 1 (1.2 or greater) of the WebKit-GTK+-bindings – version 3.0 will not work. You'll recognize that the library is missing when the Welcome Screen remains blank and opening the login window results in an error message. On Ubuntu or other Debian-based distributions, the library's package is called libwebkitgtk-1.0-0. To install it, you can try the corresponding link on the download page, search for the package in the Software Center or Synaptic, or enter the following in a terminal window:

sudo apt-get install libwebkitgtk-1.0-0

For reference, cf. the SWT FAQ (http://www.eclipse.org/swt/faq.php#browserlinux) – TextGridLab 2.0 is based on Eclipse 3.7.


Die aktuelle Version des TextGridLab (TextGridLab Base) bietet alle grundlegenden Komponenten. Das Lab wird für verschiedene Betriebssysteme als kostenloser Download auf der TextGrid-Website zur Verfügung gestellt:

http://www.textgridlab.org/download/2.0/

Plug-ins und eine Auswahl externer Werkzeuge, die für die Nutzung im TextGridLab angepasst wurden, können über den Marketplace vom Startbildschirm oder einem beliebigen anderen Punkt des Labs aus kostenlos heruntergeladen werden.

 

Systemvoraussetzungen

  • Java

Seit Version 3.3 packt das TextGridLab Java mit ein, so dass keine Probleme mehr mit falsch installierten oder fehlenden Java-Paketen auftreten. Die TextGridLab-Versionen bis 3.2 benötigten eine Java-Laufzeitumgebung (Java Runtime Environment, JRE) der Version 6 oder höher. Download:

http://java.com/download

  • Linux

Unter Linux benötigen Sie außerdem Version 1 (1.2 oder höher) des WebKit-GTK+-bindings – Version 3.0 ist nicht geeignet. Sie werden erkennen, dass die Bibliothek fehlt, wenn der Startbildschirm leer bleibt und das Öffnen des Login-Fensters eine Fehlermeldung verursacht. Unter Ubuntu oder anderen Debian-basierten Distributionen heißt das Paket libwebkitgtk-1.0-0. Um es zu installieren, können Sie den entsprechenden Link auf der Download-Seite, verwenden, im Software-Center oder Synaptic nach dem Paket suchen, oder den folgenden Befehl in einem Terminal-Fenster eingeben:

sudo apt-get install libwebkitgtk-1.0-0

Als Referenz dient die SWT FAQ (http://www.eclipse.org/swt/faq.php#browserlinux) – TextGridLab 2.0 basiert auf Eclipse 3.7.